Intermittent Inbound & Outbound Email Check Delays for EU
Monitoring·Degraded performance

A small number of email check timeouts were seen on our EU server earlier today.
Between 08:22-09:52 UTC:
Core Email Protection API - up to 0.06% of Inbound emails may have been delivered partially or fully unchecked.

We will continue to monitor and update if anything changes.

Mon, Feb 2, 2026, 11:59 AM
(18 hours ago)
·
Affected components
Updates

Monitoring

A small number of email check timeouts were seen on our EU server earlier today.
Between 08:22-09:52 UTC:
Core Email Protection API - up to 0.06% of Inbound emails may have been delivered partially or fully unchecked.

We will continue to monitor and update if anything changes.

Mon, Feb 2, 2026, 11:59 AM

Monitoring

We observed intermittent email check timeouts on our EU server earlier today.
Between 11:00-1:00 UTC:
Adaptive Email DLP - up to 6% of Outbound emails may have sent partially or fully unchecked.
Core Email Protection API - up to 2% of Inbound emails may have been delivered partially or fully unchecked.

The issue has stabilized, and our team has not seen a recurrence as we closely monitor.
We will continue to monitor through the weekend and update if anything changes.

Fri, Jan 30, 2026, 06:07 PM(2 days earlier)
Powered by