Resolved
Microsoft has now officially moved the issue to resolved, effective 19:43 UTC.
Fully details are found on this status history, under July 2024 > 30 > Tracking ID: KTY1-HW8
https://azure.status.microsoft/en-us/status/history/
Monitoring
We've observed a reduction in issues using any o365 Add-In. Microsoft recently updated their incident and are monitoring to ensure a full recovery. We will continue to follow closely.
https://azure.status.microsoft/en-us/status
Investigating
We are aware that the Tessian M365 Add-in is unable to process email due to a Network Infrastructure issue on the Microsoft side(Issues accessing a subset of Microsoft services) https://azure.status.microsoft/en-us/status