Inbound and outbound email checks delayed
Resolved
Degraded performance
Lasted for 4h

services returned to normal performance

Tue, Oct 10, 2023, 07:11 PM
7 months ago
Affected components
Tessian Cloud Email Security Platform
Updates

Resolved

services returned to normal performance

Tue, Oct 10, 2023, 07:11 PM
4h earlier...

Investigating

Inbound and outbound checks are delayed since 14:09 BST. We are investigating and working to resolve.

Tue, Oct 10, 2023, 02:21 PM
Powered by